pow
Premium Member
Registered: 11th Sep 06
Location: Hazlemere, Buckinghamshire
User status: Offline
|
Why doesn't this work
I want to use the DHCP on my 3550 switch to deal out addresses to any devices on vlan 20 (Guest) but not Vlan 10 (Company devices on the domain, server deals with DHCP).
Works on my simulator (it's a 3560 switch but that should make fuck all difference). I've omitted the bits you don't need:
The hashed password is password btw:
Current configuration : 1436 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Switch
!
!
!
enable password 7 08314D5D1A0E0A0516
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/1
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan20
description Guest-Network VLAN Interface
ip address 10.150.5.254 255.255.255.0
!
ip classless
!
!
!
!
ip dhcp pool Guest-Network
network 10.150.5.0 255.255.255.0
default-router 10.150.5.1
dns-server 10.150.5.1
!
!
!
!
!
line con 0
password 7 08314D5D1A0EA0516
login
line vty 0 4
password 7 08314D5D1A0E0A0516
login
!
!
!
end
|
pow
Premium Member
Registered: 11th Sep 06
Location: Hazlemere, Buckinghamshire
User status: Offline
|
I've setup the VLANs btw.
|
Dom
Member
Registered: 13th Sep 03
User status: Offline
|
Willay is the one you want! Unlikely to be the problem but the second to last password hash doesn't match, missing a zero.
|
willay
Moderator Organiser: South East, National Events Premium Member
Registered: 10th Nov 02
Location: Roydon, Essex
User status: Offline
|
try putting 'ip routing' in the global configuration so ip routing is enabled.
then in global
ip dhcp exlcuded-address 10.150.5.1
ip dhcp exlcuded-address 10.150.5.254
(so it doesnt assign the switch or router ip in the dhcp pool)
If that doesnt work then try
interface vlan1
no shut
exit
exit
wr mem
Might need VLAN1 enabled to do stuff like DHCP.
[Edited on 05-08-2011 by willay]
|
willay
Moderator Organiser: South East, National Events Premium Member
Registered: 10th Nov 02
Location: Roydon, Essex
User status: Offline
|
also do
ip route 0.0.0.0 0.0.0.0 10.150.5.1
So you can route packets out of the network to and from the switch's admin interface.
|
Leighton
Member
Registered: 21st Feb 01
Location: Liverpool
User status: Offline
|
Willay my hero
|
pow
Premium Member
Registered: 11th Sep 06
Location: Hazlemere, Buckinghamshire
User status: Offline
|
Thanks Will, I'll try it out onsite tomorrow
|
pow
Premium Member
Registered: 11th Sep 06
Location: Hazlemere, Buckinghamshire
User status: Offline
|
quote: Originally posted by Dom
Willay is the one you want! Unlikely to be the problem but the second to last password hash doesn't match, missing a zero.
I seem to remember pressing delete when the config was in the text editor so that's all good. The passwords are only 'password' just so I can use my simulator
|
pow
Premium Member
Registered: 11th Sep 06
Location: Hazlemere, Buckinghamshire
User status: Offline
|
Will, can I also ask, giving the device a management IP address - do you enable int VLAN 1 and give that an IP address or do you use a BVI interface?
[Edited on 05-08-2011 by pow]
|
willay
Moderator Organiser: South East, National Events Premium Member
Registered: 10th Nov 02
Location: Roydon, Essex
User status: Offline
|
just enable vlan1 and you should be able to telnet to 10.150.4.254
|
pow
Premium Member
Registered: 11th Sep 06
Location: Hazlemere, Buckinghamshire
User status: Offline
|
Reason why it wasn't working?
default-router 10.150.5.1 255.255.255.0
dns-server 10.150.5.1 255.255.255.0
DICKHEAD
|